alexandrvseznaika
08.02.2023 20:52

Работа в консольном приложении visual basic 2010. двухмерные массивы. дана квадратная матрица м размер 3х3(поставьте любые буквы или цифры) найти сумму и произведение элементов, в заданный интервал(а; в) 1) составить блок-схему выполнения (без пред программ) 2)написать программу в соответствии с блок-схемой . ,заранее

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
svetlanaivanova3
17.09.2020 10:29
Static void Main(string[] args) 
       {
            int[,] arr = new int[3, 3];
            Random c = new Random(DateTime.Now.Millisecond);
            for (int i = 0; i < 3; i++)                           
                     for (int j = 0; j < 3; j++)
                          arr[i, j] = c.Next(1, 9);          //заполнение матрицы
                                                                   //тебе это не надо, т.к. она дана           
            //заданный интервал
            int a = 3;
            int b = 3;
            int sum = 0;
            int proizvedenie = 1;
            for (int i = 0; i < a; i++)
            {
                for (int j = 0; j < b; j++)
                {
                    sum += arr[i, j];
                    proizvedenie *= arr[i, j];
                }
            }
            Console.WriteLine("Матрица:");
            Console.WriteLine("{0} {1} {2}", arr[0, 0], arr[0, 1], arr[0, 2]);                   Console.WriteLine("{0} {1} {2}", arr[1, 0], arr[1, 1], arr[1, 2]);            Console.WriteLine("{0} {1} {2}", arr[2, 0], arr[2, 1], arr[2, 2]);            Console.WriteLine("Сумма = {0}", sum);            Console.WriteLine("Произведение = {0}", proizvedenie);            Console.ReadLine();     
   }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота