PolinaDudnik
11.07.2022 20:38

Составьте программу, позволяющую проверить правописание "жи" и "ши" в строке s. выведите на экран количество допущенных ошибок и исправленную строку.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Sveta1100
17.09.2020 12:07
Var
b,i:integer;
S:string;
Begin
Readln(S);
b:=0;
For i:=1 to length(s) do 
if i<length(s) then begin
if (s[i]='ж') or (s[i]='ш') then if s[i+1]='ы' then begin s[i+1]:='и'; b:=b+1; end;

End;
Writeln(b);
Writeln(s);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота