Написать программу в паскале. найти все трехзначные числа, которые можно представить разностью между квадратом числа, образованного первыми двумя цифрами и квадратом третьей цифры. нужно!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
берсик7
03.10.2020 01:05
Вот программа:
var n,i:integer;
begin
for i:=100 to 999 do
 if i=(i div 10)*(i div 10)-(i mod 10)*(i mod 10) then writeln(i);
end.
А чисел таких оказалось всего 2:
100
147
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота