aiskfjdUe
07.01.2021 01:04

Дан текстовый файл. составьте программу, которая считывает текст из файла, вычисляет количество слов в каждой строке. вставьте в конце каждой строки количество слов и записать в новом файле.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Marmaladee
18.09.2020 10:19
Var  s          : string;  finish,k,i : longint;begin  assign(input,'input.txt'); reset(input);  assign(output,'output.txt'); rewrite(output);  finish:=0;  while(finish=0) do { если finish будет <> 0 то программа    перестанет читать текст}    begin      writeln('читать? если да, то 0 если нет, то 1');      readln(finish);      k:=0;      if finish=0        then begin               readln(s);               for i:=1 to length(s) do                 if s[i]=' '                   then inc(k);             end        else exit;      inc(k);      writeln(k);    end;end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота