vfedkina35
16.03.2022 05:40

Составьте программу с использованием структуры данных список. условие: вычислить и вывести на экран среднее арифметическое элементов списка, стоящих на четных местах. входные данные: n – количество элементов списка (целого типа); сами элементы списка. выходные данные: вычисленное значение.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mchermakov17
18.09.2020 10:22
// PascalABC.NET 3.0, сборка 1088
begin
  var n:=ReadInteger('Количество элементов в списке: ');
  var L:=new List<integer>;
  var t:integer;
  Writeln('Вводите чеез пробел целочисленные элементы списка');
  for var i:=1 to n do begin
    t:=ReadInteger; L.Add(t)
    end;
  var i:=1;
  var s:=0;
  while i<=n-1 do begin s+=L[i]; Inc(i,2) end;
  Writeln('Среднее арифметическое с четных мест равно ',
    s/(n div 2):0:3)
end.

Тестовое решение:
Количество элементов в списке: 5
Вводите чеез пробел целочисленные элементы списка
-6 12 57 32 8
Среднее арифметическое с четных мест равно 22.000
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота