hepizor
04.02.2023 17:01

Составить программу. вывести с клавиатуры целое число,и определить,есть ли в нем повторяющиеся цифры.программа должна вывести"да" или "нет". заранее .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nigap
20.09.2020 06:46
Uses crt;
var s:string;
i:integer;
l:boolean;   
m:set of char;
begin clrscr;
write('Введите число :');
readln(s); l:=false;
for i:=1 to length(s) do begin 
if  (m<>m-[s[i]]) then l:=true;
m:=m+[s[i]];
end;
if l then Writeln('Да')     
else Writeln('Нет');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота