Ева12а
21.01.2022 10:30

Даны два массива из n целых чисел.найти наименьший среди тех чисел первого массива,который не содержится во втором. напишите программу в паскале

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lopsiwk
03.10.2020 03:53
// PascalABC.NET 3.0, сборка 1128
begin
  var n:=ReadInteger('n=');
  Writeln('Первый массив:');
  var a:=ArrRandom(n,1,50).Println(',');
  Writeln('Второй массив:');
  var b:=ArrRandom(n,1,50).Println(',');
  Writeln('Минимальное значение, отсутствующее во втором массиве: ',
       a.OrderBy(x->x).Except(b.OrderBy(x->x)).Take(1))
end.

Тестовое решение:
n= 20
Первый массив:
18,1,4,1,22,14,34,18,50,9,27,41,26,11,8,34,7,35,34,33
Второй массив:
7,19,3,8,26,30,50,46,33,20,1,3,9,4,34,42,1,7,46,34
Минимальное значение, отсутствующее во втором массиве: [11]
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота