даsha3
02.06.2022 21:45

Составить программу с цикла repeat. составить программу выводящую и суммирующую любое количество целых чисел если введено 999 о на экран выводится результат суммирования.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Сангали
07.08.2020 07:08
На языке Java. Программа складывает и отрицательные и положительные числа.

class SumNum{
 public static void main(String args[]){
  try{
   long sumNum=0,numSum=new Long(new java.io.BufferedReader(new java.io.InputStreamReader(System.in)).readLine());
   do sumNum+=numSum;while((numSum>0?--numSum:++numSum)!=0);System.out.print("Результат "+sumNum);
  }catch(java.io.IOException io){
   System.out.println(" - Ошибка ввода!\n"); main(null);
  }catch(NumberFormatException nf){
   System.out.println(" - Введите целочисленное значение!\n"); main(null);
  }
 }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота