ghdvbeudv
02.06.2020 15:33

Нужно написать программу на pascalabc. вводится n чисел, найти максимальное двузначное среди них.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
anel19999
21.09.2020 12:23
Var
  n,max,i,a : longint;
begin
  readln(n); {количество чисел}
  max:=0; {чтобы вывести 0 если нет двухзначных}
  for i:=1 to n do
    begin
      readln(a); {хранить массив не надо т.к. он нигде не требуется}
      if (a>9) and (a<100) and (a>max)
        then max:=a;
    end;
  if max>0
    then writeln(max)
    else writeln('нет двухзначных чисел')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота