Vika3839
17.04.2020 13:36

Паскаль procedure f(n: integer); begin if n < = 5 then begin f(n + 2); writeln (n); f(n + 3) end end чему равна сумма всех чисел, напечатанных на экране при выполнении вызова f(l)? (и как)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ответ: 13.
А получается он вот так:

procedure F(n:integer);
begin
  Writeln('Вызов F(',n,')');
  if n <= 5 then begin
    F(n + 2);
    writeln('Процедура вывела ',n);
    F(n + 3)
    end
end;

begin
  f(1)
end.

Результат работы программы:
Вызов F(1)
Вызов F(3)
Вызов F(5)
Вызов F(7)
Процедура вывела 5
Вызов F(8)
Процедура вывела 3
Вызов F(6)
Процедура вывела 1
Вызов F(4)
Вызов F(6)
Процедура вывела 4
Вызов F(7)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота