НекоТян124
23.06.2020 22:45

Дан массив a[8] заполненный целыми числами от 0 до 40 .найти сумму элементов массива не превышающих 25. составить программу в poskal.заранее

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Quickpool
03.10.2020 08:15
надо хоть название языка программирования узнали.

const n = 8;
var a:array[1..n] of integer;
  s,i:integer;
begin
  //Заполнение массива значениями в диапазоне
  //от 0 до 40
  //и одновременно находим нужную сумму
  s:=0;
  for i:=1 to n do begin
    a[i]:=random(41);
    if a[i]<=25 then s:=s+a[i];
    write(a[i]:3);
  end;
  writeln;
  writeln('Сумма элементов <=25 равна ', s);
 end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота