вафелька6
10.09.2020 04:40

Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение всех целых чисел от 1 до n). программист торопился и написал программу неправильно. ниже фрагмент его программы, в котором содержится пять ошибок: к : = 1; f : = 0; while k f: =f * k; к: =к + 1 найдите ошибки. допишите необходимые операторы и выполните программу на компьютере. пример входных данных пример входных данных пример выходных данных введите n> 5 5! =120 введите n> 6 6! =720

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
AjdanaLife
22.09.2020 18:50
Var n,k,f:integer;
begin
write('n='); readln(n);
k:=1;
f:=1;
while k<=n do
 begin f:=f*k; k:=k+1; end;
writeln(n,'!=',f);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота