alinochkaderyu
13.04.2022 00:33

Напишите программу, которая вводит натуральное число n и определяет является ли число n совершенным. в паскале

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
anastasia106444
03.10.2020 08:36
Совершенное число - натуральное число, равное сумме всех своих собственных делителей (то есть всех положительных делителей, отличных от самого числа).
 
//Pascal
var
  n, s, i: integer;

begin
  s := 0;
  readln(n);
  // Находим делители до n-1, увеличиваем сумму s на i,
  // если i - делитель введенного числа
  for i := 1 to n - 1 do
    if n mod i = 0 then s := s + i;
 
  if s = n then
    writeln('cовершенное')
  else   
    writeln('не совершенное');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота