charaX
30.04.2023 01:44

Написать программу на паскале дана строка текста,знаков препинания в строке нет.напечатать все слова,заканчивающиеся на "ов" с функции pos

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ADRELE
03.10.2020 08:41
//Pascal ABC.NET v3.1 сборка 1172

Var
 s:string;
 i:integer;
begin
 readln(s);
 var wo:=s.ToWords(s);
 for i:=0 to length(wo)-1 do
 begin;
 delete(wo[i],pos(' ',wo[i]),1);
 if (pos('ов',wo[i])=length(wo[i])-1) then writeln(wo[i]);
 end;
end.

Пример ввода:
Иов Петров Петрон Человек
Пример вывода:
Иов
Петров
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота