XOPOSHISTIK
14.01.2020 00:29

Написать программу для pascal: выиснить является ли заданное число совершенным?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tyankitty
27.05.2020 22:43

Program Pr1;
uses crt;
var i,n,a:integer;
Begin
clrscr;
readln(n);
i:=1; a:=0;
while i<=n do begin
if (n mod i=0) and (i<>n) then a:=a+i;
inc(i);
end;
if a=n then writeln('YES')
else writeln('No');
end.

0,0(0 оценок)
Ответ:
казиба
27.05.2020 22:43

uses
SysUtils;

var
n,m,i:integer;
begin
readln(n);
m:=0;
for i := 1 to n-1 do
if m > n then break else
if (n mod i = 0) then m:=m+i;
if m=n then writeln('Yes') else
writeln('No');
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота