Войти
Регистрация
Спроси ai-bota
микс111111
14.07.2020 20:18
Написать программу, вычисляющую значение функции: y = cosx+cos2x+cos3x+…+cos30x
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
arsenijcurikov
09.04.2022 12:33
Дано целое число a проверить истеность высказывания число a является положительным...
basa4
06.02.2021 09:02
Решить паскаль у вас есть доллары. вы хотите обменять их на рубли. информация о курсе доллара в банках города хранится в массиве. в городе n банков. составить программу, определяющую,...
Nad17ka
06.02.2021 09:02
Площадь прямоугольника 18. найти большую сторону. если она в 3 раза больше меньшей стороны....
Barsvtk
29.07.2022 13:04
Дан двумерный массив а,размером n строк и м столбцов.найти максимальный элемент этого массива и вывести его координаты(номера строки и столбца,на пересечении которых находится этот...
Dasiol
02.06.2022 11:30
Разработать классы для описанных ниже объектов. У данного класса должна быть возможность: выводить себя с команды print. Определить другие методы. 1. Student: Фамилия, Имя, Отчество,...
Nastiusha2801
26.07.2022 16:18
Какие дополнительные функции есть у браузеров?...
Alexandro1888
03.03.2022 19:02
В свободные клетки квадрата впишите числа, так чтобы по всем строкам, столбцам и диагоналям в сумме получилось одно и тоже число а) 12 б) 106 в)48 6 36 10 30 4 8 112 122 108 24...
Kioppps
10.11.2021 07:39
Составить программу, печатающую числа в диапазоне от 45 до 369, которые не делятся на 6, но оканчиваются на цифру 6. нужно составить в pascal e. нужно...
Илона2407
25.02.2021 07:36
Сделайте алгоритм. через чертежник...
PRO100RAMZAN
30.04.2022 19:32
Информатика контрольгая работа...
Ответ:
robdars
30.08.2020 20:57
//Pascal ABC.NET v3.1 сборка 1172
Var
y,x:real;
i:integer;
begin
readln(x);
for i:=1 to 30 do
y:=y+cos(x*i);
writeln(y);
end.
Пример ввода:
1
Пример вывода:
-1.32716415333901
0,0
(0 оценок)
Ответ:
aminkaaverynova
30.08.2020 20:57
// PascalABC.NET 3.1, сборка 1192 от 07.03.2016
begin
var x:=ReadReal('x=');
Writeln(Range(1,30).Select(i->cos(x*i)).Sum)
end.
Тестовое решение:
x= 0.385
-2.41774673342197
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота