сhevapchichi0
06.10.2020 23:43

1. найдите наибольший элемент одномерного массива, состоящего из 12 элементов. элементы датчиком случайных чисел из интервала [-25,31] 2. массив а вводится с клавиатуры. найдите произведение отрицательных элементов с выводом на экран массива а

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
maksi71
31.07.2020 17:50
1. в C++

#include <iostream>
#include <ctime>
int main()
{
    using namespace std;
    int ar[12];
    srand(time(0));
    for (int i = 0; i < 12; i++)
        ar[i] = -25 + rand() % 57;

    int temp = ar[0];
    for (int i = 0; i < 12; i++)
        if (ar[i] > temp)
            temp = ar[i];

    for (int i = 0; i < 12; i++)
        cout << ar[i] << "  ";

    cout << endl;
    cout << "Max: " << temp;
    cout << endl;
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота