Diifekt
05.12.2021 07:06

Для заданного числа n составьте программу вычисления суммы s=1/2-1/3+1/4-1/5+..+1/n, где n натуральное число.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lera111katy
23.09.2020 12:46
///PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var i,n: integer;
    s:real;
begin
  readln(n);
  s:=0;
  for i:=2 to n do  begin
  if i mod 2=0 then s:=s+1/i
     else s:=s-1/i ;
  end;
  writeln(s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота