замёрзший
12.01.2021 00:52

Написать блок-схему и программу для паскаль! написать программу решения следующей : определить, является ли «счастливым» трамвайный билет с шестизначным номером («счастливым» считается билет, у которого сумма первых трёх чисел совпадает с суммой трёх последних чисел). ответ вывести на печать.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
fdnk1
03.10.2020 10:24
Программа:
var n,a1,a2,s1,s2:integer;
begin
write('n = '); readln(n);
a1:=n div 1000;
s1:=(a1 div 100)+(a1 div 10 mod 10)+(a1 mod 10);
a2:=n mod 1000;
s2:=(a2 div 100)+(a2 div 10 mod 10)+(a2 mod 10);
if s1=s2 then writeln('Билет счастливый')
          else writeln('Билет не счастливый')
end.
Пример:
n = 123231
Билет счастливый

Блок-схема - в прилагаемом файле.
Написать блок-схему и программу для паскаль! написать программу решения следующей : определить, явля
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота