анна2167
08.08.2021 01:17

C++напишите программу, которая заполняет массив из n элементов членами арифметической прогрессии с начальным значением x и разностью d . входная строка содержит три целых числа: начальное значение x , разность d и размер массива n , разделённые пробелом. гарантируется, что 0 < n ≤ 10000 . программа должна вывести содержимое массива: n первых членов арифметической прогрессии с начальным значением x и разностью d . входные данные 8 4 5 выходные данные 8 12 16 20 24

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Granger341
03.10.2020 10:28
#include <iostream>
using namespace std;
int main()
{
setlocale (0,"");
string mas [20];
int x;
int n;
int d;
cout<<"введите начальное число x: ";
cin >> x;
cout<<"введите число членов массива n: ";
cin >> n;
cout<<"введите разность чисел d: ";
cin >> d;
for (n;n>=1; n--)
{
cout<<x<<endl;
x=x+d;
}
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота