Паитаоаипа
30.03.2020 08:13

Дан двумерный массив. проверить, есть ли в нем одинаковые элементы. , , написать программу в паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
yellowmellow
03.10.2020 10:43
Program arr;
Const n=3;
var i, j, tmp, k, z:integer;
    c:boolean;
    a:array [1..n,1..n] of integer;

begin
c:=false;
for i:=1 to n do
  for j:=1 to n do
    read(a[i][j]);
for i:=1 to n do
  for j:=1 to n do
    begin
    tmp:=a[i][j];
    for k:=i+1 to n do
      for z:=j+1 to n do
        if tmp = a[k][z] then
        c:=true;
    end;
writeln;
for i:=1 to n do
begin
  for j:=1 to n do
    write(a[i][j], ' ');
  writeln;
end;
if c = true then
  writeln('В данном массиве есть равные друг другу элементы')
  else writeln('Элементы, равные друг другу, отсутсвуют в данном массиве');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота