vadim1231231
16.12.2022 01:35

Из каждой строки матрицы размером m*n сформировать m одномерных массивов. паскаль. и сделать блок схему

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
brijet2007
24.02.2021 01:52
Запишем таблицу распределения мест по купе:
Купе Места
1          1-4,53,54
2         5-8,51,52
3         9-12,49,50
4      13-16,47,48
5      17-20,45,46
6      21-24,43,44
7      25-28,41,42
8      29-32,39,40
9      33-36,37,38
Установим связь номера места с номером купе. Предлагается следующий (конечно же, не единственный) вариант:
\begin {cases} (n-1) \div 4 +1, \quad n=1,2,...,36 \\ (54-n) \div 2 \right \rceil +1, \quad n=37,38,...,54 \end {cases}
Здесь знаком ÷ обозначена операция целочисленного деления.

Теперь можно написать программу.  Язык программирования в задании не указан, поэтому выбран язык свободно распространяемой для целей обучения системы программирования PascalABC.Net

var
  n:integer;
begin
  Write('Укажите номер места: '); Read(n);
  Write('Место располагается в купе №');
  if n<=36 then Write((n-1) div 4 + 1)
  else Write((54-n) div 2 + 1)
end.

Тестовое решение:
Укажите номер места: 18
Место располагается в купе №5
0,0(0 оценок)
Ответ:
kravchenko1712
05.02.2023 22:32

Давай сравним все 4 числа между собой, найдём максимальное и вычтем из него N.


Код

#include <bits/stdc++.h>

using namespace std;

int main() {

   int a, b, c, d, n;

   cin >> a >> b >> c >> d >> n;

   if (a > b && a > c && a > d)

       a -= n;

   else if (b > a && b > c && b > d)

       b -= n;

   else if (c > a && c > b && c > d)

       c -= n;

   else d -= n;

   cout << a << " " << b << " " << c << " " << d << endl;

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота