tabarovavikap06jkm
09.03.2021 00:53

Напишите программу которая считает произведение цифр введенного натурального числа..

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
logpol40
25.08.2020 12:59
Var
  n, p: integer;

begin
  write('Число: ');
  readln(n);
  p := 1;
  while n > 0 do
  begin
    p := p * (n mod 10);
    n := n div 10
  end;
  writeln('Произведение цифр = ', p);
end.

Тест №1
Число: 54321
Произведение цифр = 120

Тест №2
Число: 54320
Произведение цифр = 0
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота