Yaroslava1902
10.05.2021 03:37

Написать программу в паскале: некоторая сумма денег выражена в копейках, например 317, 5050, 100. записать данную сумму в рублях и копейках, т. е. в виде: 3 руб. 17 коп., 50 руб. 50 коп., 1 руб. 00 коп. (количество копеек всегда выражается двумя цифрами).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Лена17617
03.10.2020 12:06
{В данном случае не имеет смысла возиться с числами, куда лучше подходят строки}
//Pascal ABC.NET v3.1 сборка 1172

Var
 s,c:string;
begin
 readln(s);
 c:=s[length(s)-1]+s[length(s)];
 delete(s,length(s)-1,2);
 writeln(s,' руб. ',c,' коп.');
end.

Пример ввода:
8705553535
Пример вывода:
87055535 руб. 35 коп.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота