kadnikovaliza
03.02.2022 05:02

Напишите программу, которая вводит с клавиатуры 15 реальных чисел, организовывает их хранение в массиве и определяет разность между максимальным и минимальным элементом массива.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
алия270
24.09.2020 11:17
Const n=15;
var x:array[1..15] of real;
i:integer; max,min:real;
begin
for i:=1 to n do
 begin
 write('x[',i,']=');
 readln(x[i]);
 end;
max:=x[1]; min:=x[1];
for i:=2 to n do
 begin
  if x[i]>max then max:=x[i];
  if x[i]<min then min:=x[i];
 end;
writeln('max-min = ',max,' - ',min,' = ',max-min);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота