макар95
14.11.2022 01:55

Написать программу, которая запрашивает кол-во сотен, кол-во десятков, кол-во единиц, затем записывает соответствующее число, а также сумму квадратов его цифр. сделать в программе pascalabc.net

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
pupsikira2
19.08.2020 16:54
Program test;
var
a,b,c,d,n:integer;
begin
Writeln('Введите кол-во сотен, десятков и единиц соответственно: ');
readln(a,b,c);
d:=a*100+b*10+c;
n:=sqr(a)+sqr(b)+sqr(c);
writeln('Сумма квадратов = ', n,#10, 'Само число: ',d);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота