Анна23091
19.09.2021 04:29

Написать программу,которая запрашивает с клавиатуры четырехзначное число и сравнивает в нём первую и последнюю цифры, вторую и третью цифры. если первая цифра равна четвёртой, а третья второй, то выводит на экран "палиндорм", а в противном случае "не палиндорм".

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
миссЧудесная
15.09.2020 23:39
Var
  a:integer;
begin
  write('Введите число ');
  readln(a);
  if (a div 1000 = a mod 10) and ((a div 100)mod 10 =(a div 10)mod 10)then
  writeln('Палиндром')
  else writeln('не Палиндром');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота