MishaBig
24.12.2022 23:52

Паскаль. за ! с клавиатуры вводится символьная строка. определите, сколько в ней цифр

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
iae1512p0dn07
03.10.2020 12:53
Var s:string; k,i:integer;
begin
write('Введите строку:');
readln(s);
k:=0;
for i:=1 to length(s) do
 if (s[i]>='0')and(s[i]<='9') then k:=k+1;
writeln('k = ',k);
end.

Пример:
Введите строку:
13 апреля 2016 г .
k = 6
0,0(0 оценок)
Ответ:
kate2224
03.10.2020 12:53
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  Write(ReadlnString('>').Where(c->c in ['0'..'9']).Count)
end.

Тестовое решение:
> Зде3сь спр14ята1ны 5 ци926ф5ры чи35сла8979 "пи"
15
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота