Никита563831
04.10.2022 01:14

Знатки информатики . написать программу которая определяет содержит ли массив чисел число х. массив и х - целые числа.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Гиперборея
03.10.2020 13:18
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
begin
  var n := readinteger('Размер массива ');
  //Для теста заполним массив сл. числами
  var a := arrrandom(n); a.Println;
  var x:=readinteger('Введите число Х');
  if x in a then writeln('массив содержит число ', x)
  else writeln('массив не содержит число ', x)
end.

Тест №1
Размер массива  10
96 14 36 84 55 1 74 99 72 20
Введите число Х 14
массив содержит число 14

Тест №2
Размер массива  10
59 9 8 98 75 34 52 63 62 17
Введите число Х 55
массив не содержит число 55
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота