2005Angelika
29.10.2020 05:06

Даны две точки на плоскости. напишите программу, определяющую какая из этих точек находится ближе к началу координат.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
forgalaxynexusp09txz
25.09.2020 01:14
Function VectorLength(x, y: real): real;
begin
    VectorLength := sqrt(x * x + y * y);
end;

var
    x1, x2, y1, y2: real;

begin
    readln(x1, y1);
    readln(x2, y2);
    if VectorLength(x1, y1) > VectorLength(x2, y2) then
        writeln('Point1')
    else writeln('Point2');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота