Roma1971
19.06.2020 04:51

Y=tgx при х изменяется от 0 до 10 написать программу так чтобы она решала с использованием оператора цикла

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tyuliganova
07.09.2020 21:16
Const a=0; b=10;
var x,y,h:real; n,i:integer;
begin
h:=1;
n:=round((b-a)/h);
x:=a-h;
for i:=0 to n do
 begin
 x:=x+h;
 y:=sin(x)/cos(x);
 writeln(x:4:1,'  ',y:6:3);
 end;
end.

Результат:
 0.0   0.000
 1.0   1.557
 2.0  -2.185
 3.0  -0.143
 4.0   1.158
 5.0  -3.381
 6.0  -0.291
 7.0   0.871
 8.0  -6.800
 9.0  -0.452
10.0   0.648
0,0(0 оценок)
Ответ:
perrezz
07.09.2020 21:16
Function tg(a:real):real;
begin
tg:=sin(a)/cos(a);
end;
var
y:real; x:integer;
begin
for x:=0 to 10 do begin
y:=tg(x);
writeln('Y=',y);
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота