Sonya2896
14.06.2021 07:49

Решить кто знает паскаль вот дан файл с оценками .txt учащихся написать программу которая определяет количество пятерок, четвёрок, троек. вывести их количество на экран. нужно написать в текстовом документе а с паскаля это прочитать

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ксеня228
03.10.2020 14:43
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var a:=ReadallLines('in.txt')[0].ToIntegers;
  Writeln('Исходный набор отметок'); a.Println;
  var k3:=a.Where(x->x=3).Count;
  var k4:=a.Where(x->x=4).Count;
  var k5:=a.Where(x->x=5).Count;
  Writeln('Троек- ',k3,', четверок- ',k4,', пятерок-',k5)
end.

Тестовое решение
Исходный набор отметок
3 4 4 5 5 3 4 4 5 4 3 5 5 3 5 3 4 3 3 4 5 4 4 3 4 4 3 4 5 4
Троек- 9, четверок- 13, пятерок-8

Файл с отметками in.txt дан во вложении.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота