алеся678
13.09.2021 03:37

Составьте программу замены нулевых элементов таблицы единицами контрольный пример n=5 данные : (0,5,0,60,0) результат : (1,5,1,60,1)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
yanakuzmina1
03.10.2020 15:10
Язык Pascal, работа на массиве. с заполнением с клавиатуры. Ты заполняешь 5 элементов ( через enter ), а он тебе выводит тоже самое, только с однерками вместо нулей.

Var x: array[1..5] of integer;
Var i,h:integer;
Begin
for i:= 1 to 5 do
Begin;
Readln(h);
if (h=0) then x[i]:=1 else x[i] = h;
end;
for i:=1 to 5 do
Begin;
Writeln('Элемент номер ',i,' массива: ',x[i]);
end;
readln(x);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота