trybak03
18.12.2021 14:01

Составьте программу определения наибольшего общего делителя двух натуральных чисел. на абс паскале надо

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
oliasnigur2016
03.10.2020 15:57
Var a,b,NOD:integer;
begin
write('a='); readln(a);
write('b='); readln(b);
while (a<>0)and(b<>0) do
 if a>b then a:=a mod b else b:=b mod a;
NOD:=a+b;
writeln('НОД=',NOD);
end.

Пример:
a=75
b=125
НОД=25
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота