ovrvoin2
17.11.2020 19:37

Напишите программу которая определяет является ли заданное натуральное числом квадратом некоторого натурального числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ЕvilСookie
25.08.2020 16:20
Var
n, x: longint;
begin
readln(n);
x := round(sqrt(n));
if x * x = n then
writeln('YES')
else
writeln('NO');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота