skey16
31.01.2022 01:20

Написать программу в pascal. найти разность наибольшей и наименьшей цифр 3-х значного числа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zFast88
03.10.2020 17:51
Var a, b, c, r : integer;
begin
c:=0;
r:=9;
write('Введите число: ');
readln(a);
while a div 10 <> 0 do
begin
b:=a mod 10;
a:=a div 10;
if b>c then c:=b;
if b<r then r:=b;
end;
b:=a mod 10;
a:=a div 10;
if b>c then c:=b;
if b<r then r:=b;
writeln('Разность: ', c-r);
end.
ДА ХОТЬ ДЛЯ 10 ЗНАЧНОГО
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота