marat5230
23.05.2023 07:18

Напишите программу, решающую любое квадратное уравнение. паскал

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
katenkaklimcuk
03.10.2020 18:31
Program kv_ur;
var a, b, c, d, x1,x2, x:real;
begin
read(a, b, c);
d:= sqr(b) - 4*a*c;
if d<0 then write('нет решений');
if d = 0 then
              begin
                 x:= -b/(2*a); write('один корень: ',x:5:2)
               end;
if d>0 then 
            begin
              x1:=(-b+sqrt(d))/(2*a);
              x2:=(-b-sqrt(d))/(2*a);
              write('два корня: ', 'x1=',x1:5:2,'x2=',x2:5:2)
            end
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота