Ustailia
07.08.2020 22:53

Написать программу нахождения ymax , если задана функция: y = х2 – 100х + 10, где х изменяется от хнач. до хкон. с шагом с. программа должна так же выводить и значение х, при котором y принимает максимальное значение. значения хнач., хкон. и с должны задаваться пользователем при выполнении программы. для организации цикла воспользуйтесь оператором while.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ПолинаКот197
28.09.2020 18:54
Var 
x0,xn,c:real;
x,y,xmax,ymax:real;
begin
writeln('Xнач, Xкон:'); 
readln(x0,xn);
write('С = '); readln(c);
x:=x0;
xmax:=x; ymax:=x*x-100*x+10;
while x<xn do
 begin
 x:=x+c;
 y:=x*x-100*x+10;
 if y>ymax then begin xmax:=x; ymax:=y; end;
 end;
writeln('xmax = ',xmax,'  ymax = ',ymax);
end.

Пример:
Xнач, Xкон:
-10 20
С = 1
xmax = -10  ymax = 1110
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота