vans10004
01.03.2020 14:59

Написать программу на си (метод ньютона) в соответствии с этим методом каждое следующее приближение к корню ищется по формуле: итерационный процесс уточнения корня заканчивается при достижении условия: < ε где ε – заданная точность. уравнение: 3х-4ln-5=0 отрезок содержащий корень [2; 4] точность 10^(-4)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kucm14
19.08.2020 20:47
Как-то так, прилагаю и сам сpp-файл :)

#include<stdio.h>#include<math.h>
const double EPS = 1e-4;
double f(double x){ return 3*x - 4 * log(x) - 5;}
double fp(double x){ return 3 - 4 * (1/x);}
int main(){ double prev = 2, cur; //prev - x (k-1)ое, cur - x k-тое cur = prev - f(prev)/fp(prev); while(abs(cur - prev) > EPS) { prev = cur; cur = cur - f(cur)/fp(cur); }
printf("%lf\n", cur); return 0;}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота