Нолик27
25.08.2022 16:42

Написать программу, которая вычисляет среднее арифметическое ненулевых элементов введенного с клавиатуры массива целых чисел. ниже рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). введите элементы массива (10 целых чисел) в одной строке и нажмите . -> 23 0 45 -5 12 0 -2 30 0 64 сумма элементов массива: 184 кол-во ненулевых элементов: 7 среднее арифметическое ненулевых элементов: 23.86

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Кепики
28.05.2020 19:02

var mas:array[1..10] of integer;

   i,kolvo:integer;

   b:real;

   

begin

writeln('Введите 10 целых чисел: ');

for i:=1 to 10 do

begin

read(mas[i]);

kolvo:= kolvo+1;

if (mas[i]=0) then kolvo:= kolvo-1;

end;

 

for i:=1 to 10 do  

begin

b:=mas[i] + b;

end;

 

b:= b/kolvo;

 

writeln('Количество ненулевых чисел= ', kolvo);

writeln('Среднее арифметическое ненулевых чисел= ', b);

 

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота