NeZnaiYProsto
01.05.2020 09:50

Составить программу для паскаля.1)определить количество трехзначных чисел сума цифр которых равна числу n.2)дано натуральное число n.составить программу меняющихся местами первую и последнюю цифру.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ЭтоКтоТо
03.10.2020 20:56
1)
var  s: string;
  i, n,c: integer;
begin
  read(n);
  for i := 100 to 999 do
  begin
    s:=inttostr(i);
    c:=(strtoint(s[1])+strtoint(s[2])+strtoint(s[3]));
    if(n=c)then writeln(s);
  end;
end.

2)
var  s: string;
begin
  read(s);
  swap(s[1],s[s.Length]);
  write(s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота