4elo100
05.05.2023 16:09

Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного числа. (abc pascal)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
jullii55
03.10.2020 22:29
Var
a,chislo,t:longint; 
c,nov,posl:integer; 
begin 
readln(a); 
posl:=a mod 10; 
chislo:=a; 
t:=1; 
repeat 
a:=a div 10; 
t:=t*10; 
until a<10; 
chislo:=chislo mod t; 
chislo:=posl*t+chislo-posl+a; 
writeln(chislo); 
readln; 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота