zibrov06
07.02.2020 09:40

Склавиатуры вводится натуральное число n. программа выводит максимальную нечетную цифру числа. написать программу на паскале.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikita1197
04.10.2020 00:07
Var
    max, n, t: integer;

begin
    readln(n);
    max := -1;
    while n > 0 do
    begin
        t := n mod 10;
        if (t mod 2 = 1) and (max < t) then
            max := t;
        n := n div 10;
    end;
    
    if max = -1 then writeln('Нет такого числа')
    else
        writeln('Max = ', max);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота