я001
23.07.2020 13:30

Написать программу на паскале 1.написать функцию,подсчитывающую количество единиц в числе и с её определить,в каком из двух чисел единиц больше.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
bonusalixova
04.10.2020 03:38
Var
  s, s2: string;

 function one(s: string): integer;
var i, c: integer;
begin
  c := 0;
  for i := 1 to length(s) do
    if (s[i] = '1') then c := c + 1;
  result := c;
end;

 begin
  writeln('Введите первое число:');
  readln(s);
  writeln('Введите второе число:');
  readln(s2);
  if(one(s) > one(s2)) then write('В первом числе больше единиц')
  else write('Во втором числе больше единиц');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота