Лилия200000
04.01.2020 16:16

Написать программу на языке с++: из данной строки удалить все цифры и малые латинские буквы

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ksushaybff
04.10.2020 03:41
//Dev-C++ 5.11

#include <iostream>
#include <string>
using namespace std;

int main(void)
 {string s;
 int i=0,k=0;
 cin>>s;
 k=s.length();
 while (k!=i)
  {if((s[i]>='0'&&s[i]<='9')||(s[i]>='a'&&s[i]<='z'))
   s.erase(s.begin()+i);
  else
   i++;
  k=s.length();}
 cout<<endl<<s;
 return 0;}

Пример ввода:
WaTerMeL1oN
Пример вывода:
WTMLN
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота