nikita6011
31.10.2020 04:06

15 , написать программу на pascal. условие: дан массивиз 15 элементов. 1)найти сумму чисел элементов являющихся нечётными числами с чётным индексом 2)найти сумму элементов индексы которых это две . заранее большое ! ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
longassride
29.05.2020 07:34

Объяснение:

вот обе задачи, во втором я так понял, нужно просто нечетные индексы?


15 , написать программу на pascal. условие: дан массивиз 15 элементов. 1)найти сумму чисел элементов
0,0(0 оценок)
Ответ:
HotaruAnastasija
29.05.2020 07:34

var M:array[0..15]of integer;

     k, i, sum ,inp : integer;

begin

  for  k := 0 to 15 do begin

      writeln('Введите ', k , ' элемент массива:');

      readln(M[k]);

  end;

   

  for i := 0 to 15 do begin

        if (i mod 2 = 0) then  

        begin

            if (M[i] mod  2 = 0) then

            begin

                 sum := sum + M[i];

            end;

        end;

  end;

   

writeln('Вывод : ' , sum - M[0]);

readln;

end.

Объяснение: ответ к первой части.В общем: в этой программе 0 не считается чётным числом, поэтому 0-вой индекс, даже если его число чётное - не считается . Если вы с этим не согласны то вам всего лишь нужно из этой строчки: writeln('Вывод : ' , sum - M[0]); сделать writeln('Вывод : ' , sum);

Вторая задача :

var M:array[0..15]of integer;

     k, i, sum ,inp : integer;

begin

  for  k := 0 to 15 do begin

      writeln('Введите ', k , ' элемент массива:');

      readln(M[k]);    

  end;

   

  for i := 0 to 15 do begin

        if (i mod 2 <> 0) then  

            sum := sum + M[i];

  end;

   

writeln('Вывод : ' , sum);

readln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота