polonnikovdanil
07.10.2021 22:28

Составить программу на паскале. в массиве хранится информация о стоимости каждой из m книг. определить количество самых дешевых книг(с одинаковой минимальной ценой)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zenfnfsj
04.10.2020 08:03
Var mas:array of integer;    min,kol ,j, i,n:integer;
begin
Randomize; min:=0;kol:=0;
write('n:' );
readln(n);   
setlength(mas,length(mas)+n);///динамический массив вы можете заменить на статический 
 For i:= 0 to high(mas) do 
  mas[i]:=Random(50);   
min:=mas[0]; 
 for j:=0 to high(mas) do//ищем минимальную ценну 
 if min>mas[j] then 
 min:=mas[j] ; 
 For i:= 0 to high(mas) do 
 if min=mas[i] then//ищем количество книг с минимальной ценой
   inc(kol);   
write('kolvo min  ',kol); 
 readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота