pfbrfyfnfkmz
28.05.2023 12:51

Информатика! нужно составить программу на языке паскаль. мама выдала сыну саше сумму денег xна карманные расходы. ежедневно саша в конце дня подводил итоги своим тратам и заносил их в программу. требуется определить на сколько дней ему хватило денег и сколько денег осталось.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DemonDem25
29.05.2020 10:43

program raf105;

var mama,sum,rub,day:integer;

begin

write('Какую сумму денег мама выдала сыну? >> ');

readln(mama);

writeln('Введите сумму, которую вы потратили за один день');

writeln('Что бы узнать оставшиеся и потраченные деньги введите "-1"');

sum:=mama;

while sum<>0 do

begin

 readln(rub);

 if sum-rub >= 0  

   then

   if rub=-1  

     then

     begin

       writeln('У вас осталось ',sum,' руб.');

       writeln('Вы потратили ',mama-sum,' руб. за ',day,' дн.');

     end

     else

      begin

        sum:= sum-rub;

        day:= day+1;

      end

    else writeln('У вас недостаточно денег, что бы потратить такую сумму');

end;

writeln('У вас закончились деньги');

writeln('Вы потратили их за ',day,' дн.');

end.

Написано на языке PascalABC.NET

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота