davo20051
31.07.2022 08:39

Написать программу которая считает количество цифр в числе и их сумму. паскаль. число вводится с клавиатуры

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nonyshko
04.10.2020 10:26
Для натуральных чисел:
var a,k,s:integer;
begin
write('a = ');
readln(a);
k:=0; s:=0;
while a>0 do
 begin
 k:=k+1;
 s:=s+a mod 10;
 a:=a div 10;
 end;
writeln('k = ',k,', s = ',s);
end.

Пример:
a = 352186
k = 6, s = 25
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота