anjnazarova
07.01.2021 01:19

Решить. напишите программу формирования массива размером 5х5 с датчика случайных чисел замените в нем значения элементов с четной суммой индексов на значение второго элемента массива из первой строки. выведите на экран исходный и измененный массив. (паскаль абс) с объяснением

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ольга2465
08.09.2020 12:50
Const
n=5;
var
a:array[1..n,1..n] of integer;
i,j:integer;

begin
//генератор случайных чисел. Диапазон от 1 до 10.
 for i:=1 to n do
  begin
  for j:=1 to n do
   begin
    a[i,j]:=random(10)+1;
    write(a[i,j]," ");
   end;
   writeln();
  end;

//Проверка условия и переприсвоение, если верно.
 for i:=1 to n do
  for j:=1 to n do
   begin
    if (((i+j) mod 2)=0) then
     a[i,j]:=a[1,2];
   end; 
 
//Вывод полученного массива.
  for i:=1 to n do
  begin
  for j:=1 to n do
   begin
    write(a[i,j]," ");
   end;
   writeln();
  end;

//Ожидание.
readln();
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота